using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Owner\:\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)";
string input = @"
Owner: Don't say ""digger""
Owner:digger
Owner: Digger
Owner: don't use bag as an insult
Owner:(anything else here)digg
here we have digg
also bag
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}