re = /Owner\:\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)/mi
str = '
Owner: Don\'t say "digger"
Owner:digger
Owner: Digger
Owner: don\'t use bag as an insult
Owner:(anything else here)digg
here we have digg
also bag
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end