const regex = /Owner\:\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Owner\\:\\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)', 'gmi')
const str = `
Owner: Don't say "digger"
Owner:digger
Owner: Digger
Owner: don't use bag as an insult
Owner:(anything else here)digg
here we have digg
also bag
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}