package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)Owner\:\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)`)
var str = `
Owner: Don't say "digger"
Owner:digger
Owner: Digger
Owner: don't use bag as an insult
Owner:(anything else here)digg
here we have digg
also bag
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}