import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Owner\\:\\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)";
final String string = "\n"
+ "Owner: Don't say \"digger\"\n"
+ "Owner:digger\n\n"
+ "Owner: Digger\n\n"
+ "Owner: don't use bag as an insult\n\n"
+ "Owner:(anything else here)digg\n\n"
+ "here we have digg\n\n"
+ "also bag\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}