// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)Owner\:\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)").unwrap();
let string = "
Owner: Don't say \"digger\"
Owner:digger
Owner: Digger
Owner: don't use bag as an insult
Owner:(anything else here)digg
here we have digg
also bag
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}