$re = '/Owner\:\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)/mi';
$str = '
Owner: Don\'t say "digger"
Owner:digger
Owner: Digger
Owner: don\'t use bag as an insult
Owner:(anything else here)digg
here we have digg
also bag
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);