use strict;
my $str = '
Owner: Don\'t say "digger"
Owner:digger
Owner: Digger
Owner: don\'t use bag as an insult
Owner:(anything else here)digg
here we have digg
also bag
';
my $regex = qr/Owner\:\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}