import re
regex = re.compile(r"Owner\:\s*.*?(digg|bag)(*SKIP)(*F)|(digg|bag)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\n"
"Owner: Don't say \"digger\"\n"
"Owner:digger\n\n"
"Owner: Digger\n\n"
"Owner: don't use bag as an insult\n\n"
"Owner:(anything else here)digg\n\n"
"here we have digg\n\n"
"also bag\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")