# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(#[a-z]+\\n)|\\n(?!#)/\1/g;t' <<< "bla1;\nbla2;\nbla3;\n#endif\nbla4;"