import re
regex = re.compile(r"(#[a-z]+\\n)|\\n(?!#)")
test_str = "bla1;\\nbla2;\\nbla3;\\n#endif\\nbla4;"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)