$re = '/(#[a-z]+\\\\n)|\\\\n(?!#)/';
$str = 'bla1;\\nbla2;\\nbla3;\\n#endif\\nbla4;';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;