import Foundation
let pattern = ##"(#[a-z]+\\n)|\\n(?!#)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"bla1;\nbla2;\nbla3;\n#endif\nbla4;"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)