#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(#[a-z]+\\n)|\\n(?!#)"
Local $sString = "bla1;\nbla2;\nbla3;\n#endif\nbla4;"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)