const regex = /(#[a-z]+\\n)|\\n(?!#)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#[a-z]+\\\\n)|\\\\n(?!#)', 'g')
const str = `bla1;\\nbla2;\\nbla3;\\n#endif\\nbla4;`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);