use strict;
my $str = 'bla1;\\nbla2;\\nbla3;\\n#endif\\nbla4;';
my $regex = qr/(#[a-z]+\\n)|\\n(?!#)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";