re = /(#[a-z]+\\n)|\\n(?!#)/
str = 'bla1;\\nbla2;\\nbla3;\\n#endif\\nbla4;'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result