#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d{4}(?!$)"
Local $sString = "1111222233334444" & @CRLF & _
"111122223333444" & @CRLF & _
"11112222333344" & @CRLF & _
"1111222233334" & @CRLF & _
"111122223333" & @CRLF & _
"11111" & @CRLF & _
"9999"
Local $sSubst = "$&-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)