import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}(?!$)";
final String string = "1111222233334444\n"
+ "111122223333444\n"
+ "11112222333344\n"
+ "1111222233334\n"
+ "111122223333\n"
+ "11111\n"
+ "9999";
final String subst = "$&-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}