use strict;
my $str = '1111222233334444
111122223333444
11112222333344
1111222233334
111122223333
11111
9999';
my $regex = qr/\d{4}(?!$)/mp;
my $subst = '$&-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";