using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{4}(?!$)";
string substitution = @"$&-";
string input = @"1111222233334444
111122223333444
11112222333344
1111222233334
111122223333
11111
9999";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}