import Foundation
let pattern = #"\d{4}(?!$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1111222233334444
111122223333444
11112222333344
1111222233334
111122223333
11111
9999
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$&-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)