const regex = /\d{4}(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{4}(?!$)', 'gm')
const str = `1111222233334444
111122223333444
11112222333344
1111222233334
111122223333
11111
9999`;
const subst = `$&-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);