# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[[:punct:]]*span[[:punct:]]*//g;t' <<< "somethingspan. ..span? spanthank great to hear yourspan"