#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[[:punct:]]*span[[:punct:]]*"
Local $sString = "somethingspan. ..span? spanthank great to hear yourspan"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)