use strict;
my $str = 'somethingspan. ..span? spanthank great to hear yourspan';
my $regex = qr/[[:punct:]]*span[[:punct:]]*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";