using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:punct:]]*span[[:punct:]]*";
string substitution = @"";
string input = @"somethingspan. ..span? spanthank great to hear yourspan";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}