import Foundation
let pattern = #"[[:punct:]]*span[[:punct:]]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"somethingspan. ..span? spanthank great to hear yourspan"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)