$re = '/[[:punct:]]*span[[:punct:]]*/';
$str = 'somethingspan. ..span? spanthank great to hear yourspan';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;