package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[[:punct:]]*span[[:punct:]]*`)
var str = `somethingspan. ..span? spanthank great to hear yourspan`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}