const regex = /[[:punct:]]*span[[:punct:]]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[[:punct:]]*span[[:punct:]]*', 'g')
const str = `somethingspan. ..span? spanthank great to hear yourspan`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);