use strict;
my $str = '"Yes/No"
"Yes / No"
"Yes/ No"
"Yes /No"
"Yes / No"';
my $regex = qr~\h*/\h*~p;
my $subst = ' / ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";