#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:"[^"\n]*"|[^:,\n])*):((?:"[^"\n]*"|[^,\n])*)"
Local $sString = "PATH_1:"/", PATH_2:"/OtherPath", TODAY:"2016-06-27",XYZ :"1234"" & @CRLF & _
"" & @CRLF & _
"PATH_1:"c:\", PATH_2:"c:\OtherPath", TODAY:"2016-06-27"" & @CRLF & _
"" & @CRLF & _
"PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234" & @CRLF & _
"" & @CRLF & _
"PATH_1:c:\, PATH_2:c:\OtherPath, TODAY:2016-06-27"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")