import Foundation
let pattern = #"((?:"[^"\n]*"|[^:,\n])*):((?:"[^"\n]*"|[^,\n])*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
PATH_1:"/", PATH_2:"/OtherPath", TODAY:"2016-06-27",XYZ :"1234"
PATH_1:"c:\", PATH_2:"c:\OtherPath", TODAY:"2016-06-27"
PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234
PATH_1:c:\, PATH_2:c:\OtherPath, TODAY:2016-06-27
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)