$re = '/((?:"[^"\n]*"|[^:,\n])*):((?:"[^"\n]*"|[^,\n])*)/';
$str = 'PATH_1:"/", PATH_2:"/OtherPath", TODAY:"2016-06-27",XYZ :"1234"
PATH_1:"c:\\", PATH_2:"c:\\OtherPath", TODAY:"2016-06-27"
PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234
PATH_1:c:\\, PATH_2:c:\\OtherPath, TODAY:2016-06-27';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);