using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:""[^""\n]*""|[^:,\n])*):((?:""[^""\n]*""|[^,\n])*)";
string input = @"PATH_1:""/"", PATH_2:""/OtherPath"", TODAY:""2016-06-27"",XYZ :""1234""
PATH_1:""c:\"", PATH_2:""c:\OtherPath"", TODAY:""2016-06-27""
PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234
PATH_1:c:\, PATH_2:c:\OtherPath, TODAY:2016-06-27";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}