package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:"[^"\n]*"|[^:,\n])*):((?:"[^"\n]*"|[^,\n])*)`)
var str = `PATH_1:"/", PATH_2:"/OtherPath", TODAY:"2016-06-27",XYZ :"1234"
PATH_1:"c:\", PATH_2:"c:\OtherPath", TODAY:"2016-06-27"
PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234
PATH_1:c:\, PATH_2:c:\OtherPath, TODAY:2016-06-27`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}