import re
regex = re.compile(r"((?:\"[^\"\n]*\"|[^:,\n])*):((?:\"[^\"\n]*\"|[^,\n])*)")
test_str = ("PATH_1:\"/\", PATH_2:\"/OtherPath\", TODAY:\"2016-06-27\",XYZ :\"1234\"\n\n"
"PATH_1:\"c:\\\", PATH_2:\"c:\\OtherPath\", TODAY:\"2016-06-27\"\n\n"
"PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234\n\n"
"PATH_1:c:\\, PATH_2:c:\\OtherPath, TODAY:2016-06-27")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")