// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"((?:"[^"\n]*"|[^:,\n])*):((?:"[^"\n]*"|[^,\n])*)"#).unwrap();
let string = "PATH_1:\"/\", PATH_2:\"/OtherPath\", TODAY:\"2016-06-27\",XYZ :\"1234\"
PATH_1:\"c:\\\", PATH_2:\"c:\\OtherPath\", TODAY:\"2016-06-27\"
PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234
PATH_1:c:\\, PATH_2:c:\\OtherPath, TODAY:2016-06-27";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}