const regex = /((?:"[^"\n]*"|[^:,\n])*):((?:"[^"\n]*"|[^,\n])*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:"[^"\\n]*"|[^:,\\n])*):((?:"[^"\\n]*"|[^,\\n])*)', 'g')
const str = `PATH_1:"/", PATH_2:"/OtherPath", TODAY:"2016-06-27",XYZ :"1234"
PATH_1:"c:\\", PATH_2:"c:\\OtherPath", TODAY:"2016-06-27"
PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234
PATH_1:c:\\, PATH_2:c:\\OtherPath, TODAY:2016-06-27`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}