import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\"[^\"\\n]*\"|[^:,\\n])*):((?:\"[^\"\\n]*\"|[^,\\n])*)";
final String string = "PATH_1:\"/\", PATH_2:\"/OtherPath\", TODAY:\"2016-06-27\",XYZ :\"1234\"\n\n"
+ "PATH_1:\"c:\\\", PATH_2:\"c:\\OtherPath\", TODAY:\"2016-06-27\"\n\n"
+ "PATH_1:/, PATH_2:/OtherPath, TODAY:2016-06-27,XYZ :1234\n\n"
+ "PATH_1:c:\\, PATH_2:c:\\OtherPath, TODAY:2016-06-27";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}