# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(person\s*=\s*{[^}]*'name'\s*:\s*')(.*?)(')/\1What an ugly design\3/s;t' <<< "person = {
'name' : 'Jhon Dow',
'address' : 'London',
'age' : 26,
'isMarried' : True ,
'brothersNames' : ['Kim' , 'David' , 'Ron']
}
animal = {
'type' : 'Lion',
'name' : 'Simba',
'age' : 10,
}"