const regex = /(person\s*=\s*{[^}]*'name'\s*:\s*')(.*?)(')/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(person\\s*=\\s*{[^}]*\'name\'\\s*:\\s*\')(.*?)(\')', 's')
const str = `person = {
'name' : 'Jhon Dow',
'address' : 'London',
'age' : 26,
'isMarried' : True ,
'brothersNames' : ['Kim' , 'David' , 'Ron']
}
animal = {
'type' : 'Lion',
'name' : 'Simba',
'age' : 10,
}`;
const subst = `\1What an ugly design\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);