// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(person\s*=\s*{[^}]*'name'\s*:\s*')(.*?)(')").unwrap();
let string = "person = {
'name' : 'Jhon Dow',
'address' : 'London',
'age' : 26,
'isMarried' : True ,
'brothersNames' : ['Kim' , 'David' , 'Ron']
}
animal = {
'type' : 'Lion',
'name' : 'Simba',
'age' : 10,
}";
let substitution = "\\1What an ugly design\\3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}