re = /(person\s*=\s*{[^}]*'name'\s*:\s*')(.*?)(')/
str = 'person = {
\'name\' : \'Jhon Dow\',
\'address\' : \'London\',
\'age\' : 26,
\'isMarried\' : True ,
\'brothersNames\' : [\'Kim\' , \'David\' , \'Ron\']
}
animal = {
\'type\' : \'Lion\',
\'name\' : \'Simba\',
\'age\' : 10,
}'
subst = '\\1What an ugly design\\3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result