use strict;
my $str = 'person = {
\'name\' : \'Jhon Dow\',
\'address\' : \'London\',
\'age\' : 26,
\'isMarried\' : True ,
\'brothersNames\' : [\'Kim\' , \'David\' , \'Ron\']
}
animal = {
\'type\' : \'Lion\',
\'name\' : \'Simba\',
\'age\' : 10,
}';
my $regex = qr/(person\s*=\s*{[^}]*'name'\s*:\s*')(.*?)(')/sp;
my $subst = '\\1What an ugly design\\3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";