import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(person\\s*=\\s*\\{[^\\}]*'name'\\s*:\\s*')(.*?)(')";
final String string = "person = {\n"
+ " 'name' : 'Jhon Dow',\n"
+ " 'address' : 'London',\n"
+ " 'age' : 26,\n"
+ " 'isMarried' : True ,\n"
+ " 'brothersNames' : ['Kim' , 'David' , 'Ron']\n"
+ "} \n\n"
+ "animal = {\n"
+ " 'type' : 'Lion',\n"
+ " 'name' : 'Simba',\n"
+ " 'age' : 10,\n"
+ "}";
final String subst = "\\1What an ugly design\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}