# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)\s*(?=(?:st|nd|rd|th)\b)//g;t' <<< "foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th"