const regex = new RegExp('(?<=\\d)\\s*(?=(?:st|nd|rd|th)\\b)', 'g')
const str = `foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);