using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)\s*(?=(?:st|nd|rd|th)\b)";
string substitution = @"";
string input = @"foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}